Cómo utilizar QT5 y Qt Creator 2.6.1 con el compilador de VS 2012?

votos
14

Los oficiales descargas sólo se incluyen las bibliotecas Qt 5.0.0 para VS 2010 ahora. Las probé en VS 2012 Express, pero tengo un mensaje de error como error: LNK2038: desajuste detectado para '_MSC_VER': valor '1600' no coincide con el valor '1700' ...

¿Tengo que instalar VS 2010 o compilar el código fuente completo de QT5 en VS 2012?

ACTUALIZACIÓN: Mi IDE es Qt Creator 2.6.1. Yo sólo uso el compilador de C ++ en VS 2012 porque no hay bibliotecas Qt 5.0.0 para Mingw en los oficiales descargas todavía.

ACTUALIZACIÓN-2 (01/01/2013): Saw hoy en día, el blog oficial dice:

Hay algunas cosas que todavía estamos trabajando para la serie 5.0. Tenemos errores que queremos corregir. En este momento no tenemos los paquetes binarios para MinGW (como WebKit aún no funciona con ella todavía) y MSVC 2012 (que necesitará para compilar desde el código fuente), y vamos a trabajar en la entrega de estos tan pronto como sea posible. El plan actual es tener una primera versión de nivel de parches, 5.0.1, algún tiempo antes de finales de enero.

ACTUALIZACIÓN-3 (01/31/2013): Eso viene por último, pero sólo añade Qt 5.0.1 para MinGW 4.7.

ACTUALIZACIÓN-4 (07/06/2013): Después de una larga espera, Qt 5.1.0 para Windows de 32 bits (VS 2012, 511 MB) añadió.

Publicado el 20/12/2012 a las 07:40
fuente por usuario
En otros idiomas...                            


2 respuestas

votos
2

¿Qué es lo que ha establecido en 2012 Visual Studio ?

Propiedades del proyecto> General> conjunto de herramientas Plataforma

Inténtelo de a v110.

Más información en MSDN .

Respondida el 20/12/2012 a las 07:48
fuente por usuario

votos
5

Tienes razón - si desea utilizar MS VC 2012 compilador, debe compilar las bibliotecas QT5 manualmente. El tutorial se puede encontrar en http://qt-project.org/wiki/Building_Qt_5_from_Git . Otra opción es instalar VS 2010 y utilizarlo hasta Digia hará bibliotecas precompilados VC 2012 y MinGW. Si utiliza Qt Creator como su IDE primario, debería ser suficiente para instalar sólo VC 2010 Express.

Respondida el 25/12/2012 a las 06:56
fuente por usuario

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more