resaltado de sintaxis incorrecta para el archivo PHP en PhpStorm

votos
133

No sé lo que pasó, pero resaltado de sintaxis para un archivo PHP dejó de trabajar y también icono al lado del archivo ha cambiado. Esto demuestra que es un archivo de texto en lugar de PHP.

Cómo puedo arreglar eso ?

Publicado el 29/11/2010 a las 18:15
fuente por usuario
En otros idiomas...                            


7 respuestas

votos
307

Ir a Ajustes | Tipos de archivos y asegúrese de que el nombre de archivo en particular no está asignado a la no-PHP tipo de archivo, es decir, texto sin formato.

Respondida el 17/01/2011 a las 17:53
fuente por usuario

votos
13

No estoy seguro de si esta función se limita sólo a PhpStorm 9, pero no hay una solución más simple: si la extensión de un archivo .php es, puede hacer clic derecho sobre el archivo en el menú de navegación del proyecto y haga clic en "Marcar como php". Que fija el problema para mí.

Respondida el 03/08/2015 a las 11:29
fuente por usuario

votos
36

En PhpStorm 10, tiene que ir a Archivo-> Configuración y una vez allí Editor-> Tipo de archivo. Si el texto sin formato, probablemente lo encontrará en el tipo de archivo "de texto". Compruebe debajo de "patrones" registeded y borrar el archivo desde allí.

Respondida el 17/02/2016 a las 12:27
fuente por usuario

votos
14

La forma más fácil de solucionar este problema es ir a File > Settingsen Windows (o PHPStorm > Preferencesen MacOS), a continuación, busque "Tipos de archivo".

Desplazarse hacia abajo para el tipo de archivo problemático (en este caso PHP).

A continuación, busque la extensión de archivo esperada (en este caso .php).

introducir descripción de la imagen aquí

Si ve que le falta (como antes), a continuación, sólo tiene que añadir pulsando el botón + en "patrones registrados". Luego, en la ventana "Añadir Comodín" que se abre debería escribir:*.php

introducir descripción de la imagen aquí

PhpStorm entonces le dirá que la que está asignada a otro tipo de archivo (el que ha causado este problema), y le gustaría moverlo a éste en su lugar. Simplemente haga clic en "Sí" y va a arreglar todo. todo lo que está!

Esto es mucho más fácil que la caza alrededor de los otros tipos de archivos para un roto eliminar.

Respondida el 17/05/2016 a las 11:45
fuente por usuario

votos
0

Esta pregunta es viejo, pero me contesta para alguien que no podía resolver esto:

Es posible que haya eliminado una de inicio de PHP ( <? php) o al final ( ?>) las etiquetas, por lo que se visualiza en texto plano

Respondida el 15/11/2017 a las 17:14
fuente por usuario

votos
3

Gracias a @Scotty Waggoner

Por alguna razón se añadió todo el nombre de archivo para el tipo de archivo de texto.

Encuentra el archivo en Ajustes | FileTypes | texto | RegisteredPatterns y retirarla.

Respondida el 13/12/2017 a las 04:59
fuente por usuario

votos
0

En PhpStorm 2.019,1 en MacOS:

PhpStorm > Preferences > Editor > File Types > Recognized File Types > Text

Eliminar la entrada de Registered Patternsla que contiene su nombre de archivo, es decir, eliminar File.php, si File.phpes el archivo problemático.

Respondida el 18/04/2019 a las 09:43
fuente por usuario

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more