Yo tratando de correr Android Studio, pero tienen errores syn grado. Hay cinco errores de dependencia, la depuración. cuál es la solución

votos
0

Estoy utilizando la versión 3.1.4 y el grado androide He intentado 4.4 4.5 4.10 y el más reciente 5.6.2 pero ninguna de ellas parece ayudar. La versión más reciente muestra algunos otros errores sin embargo. ¿Cuál es la solución?

Publicado el 09/10/2019 a las 18:49
fuente por usuario
En otros idiomas...                            


1 respuestas

votos
0

Para api min 21 y el objetivo 28, tengo la siguiente configuración de mi build.gradle (Módulo: app) de archivos.

apply plugin: 'com.android.application'

android {
compileSdkVersion 28
defaultConfig {
    applicationId "com.example.yourprojectname"
    minSdkVersion 21
    targetSdkVersion 28
    versionCode 1
    versionName "1.0"
    testInstrumentationRunner "android.support.test.runner.AndroidJUnitRunner"
    vectorDrawables.useSupportLibrary = true
}
buildTypes {
    release {
        minifyEnabled false
        proguardFiles getDefaultProguardFile('proguard-android-optimize.txt'), 
'proguard-rules.pro'
    }
 }
 }

 dependencies {
     implementation fileTree(dir: 'libs', include: ['*.jar'])
     implementation 'com.android.support:appcompat-v7:28.+'
     implementation 'com.android.support:support-v4:28.+'
     implementation 'com.android.support:design:28.+'
     implementation 'com.android.support.constraint:constraint-layout:1.0.2'
     testImplementation 'junit:junit:4.12'
     androidTestImplementation 'com.android.support.test:runner:1.0.1'
     androidTestImplementation 'com.android.support.test.espresso:espresso- 
     core:3.0.1'

}

Si usted tiene un nivel min API diferente, cambiar la propiedad a su minSdkVersion activos y de sincronización en directo. Espero que esto ayude.

Respondida el 11/10/2019 a las 17:07
fuente por usuario

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more