No se puede iniciar un contenedor existente con Podman

votos
0

Me postulo Podman en Ubuntu 18.04. Soy incapaz de iniciar un contenedor después de detenerlo.

Corro el recipiente con:

podman run -d -p 8081:8081 --name nexus -v /opt/nexus-data:/nexus-data sonatype/nexus3

Y se pone en marcha bien. Si me quedo:

podman container stop nexus
podman container start nexus

Me aparece un error: Error: no puede iniciar contenedor nexo: recipiente Error de creación (no hay registros de conmon): EOF

Cuando se ejecuta con el registro de depuración que veo esto en la salida:

Debu [0000] backend acontecimiento iniciador journald
Debu [0000] utilizando el tiempo de ejecución / usr / lib / cri-o-Runc / sbin / Runc WARN [0000] Error al inicializar configurado OCI tiempo de ejecución crun: No se han encontrado ejecutable válido para la OCI crun tiempo de ejecución: argumento no válido .... Debu [0000] contenedores sin montar 419f6576ff23328c6445526058c9988aa27a4b69605348230fa26246a522c726 ERRO [0000] no puede iniciar contenedor nexo: recipiente falló Crear (no hay registros de conmon): EOF

La imagen original es: docker.io/sonatype/nexus3

No estoy seguro de lo que el argumento no válido en los medios troncos. Qué necesito para pasar a otro argumento?

Publicado el 14/01/2020 a las 00:02
fuente por usuario
En otros idiomas...                            


2 respuestas

votos
0

parece que hay un problema con la última versión del conmonpaquete de proyecto atómico PPA (v 2.0.3).

Yo tenía el mismo problema y he instalado una versión inferior del conmonpaquete (v 2.0.0) de, https://launchpad.net/ubuntu/+archive/primary/+files/conmon_2.0.0-1_amd64.deb

Este es un paquete construido para EOAN. Sin embargo, se trabajó en mi entorno biónica y yo soy capaz de iniciar mis contenedores de nuevo.

Respondida el 14/01/2020 a las 09:36
fuente por usuario

votos
0

Como se ha señalado @Loki Arya, un error en el paquete común fue la causa del problema. Desde Podman para Unbuntu ya no está siendo alojado en ppa projectatomic, las actualizaciones después de que la versión 1.6.2 Corregido el error no estaban disponibles.

Después de la eliminación de las PPA atómicas del proyecto y todos los paquetes asociados, Reinstalé Podman para Ubuntu desde su nueva ubicación de repositorio aquí

He probado Podman (1.7) y está trabajando muy bien, incluyendo el comando de inicio

Respondida el 18/01/2020 a las 19:22
fuente por usuario

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more