bibliotecas com.android.support deben utilizar la misma versión de la especificación exacta y [] problemas con los servicios de Google Play

votos
0

Estoy tratando de utilizar el relleno automático de Google placesApi y la distancia / mapas de la API de Google Maps. Me encuentro con un problema de compatibilidad cuando agrego tanto a mis dependencias (versión 26.1.0 para los lugares). Sin embargo, cuando traté de arreglarlo por aplicar cardview de 27.1.1, el mapa no muestra más, y dice: Mi aplicación está teniendo problemas con los servicios de Google Play.

Mi dependencia es la siguiente:

dependencies {
    implementation fileTree(dir: 'libs', include: ['*.jar'])
    implementation 'com.android.support:appcompat-v7:27.1.1'

    implementation 'com.android.support.constraint:constraint-layout:1.1.3'
    implementation 'com.google.android.gms:play-services-maps:10.0.1'
    testImplementation 'junit:junit:4.12'
    androidTestImplementation 'com.android.support.test:runner:1.0.2'
    androidTestImplementation 'com.android.support.test.espresso:espresso-core:3.0.2'
    implementation 'com.android.support:design:27.1.1'

    // 1. So far, Google Maps work


    // 2. After adding the following code --> Compatibility issue (27.1.1 vs 26.1.0)
    //implementation 'com.google.android.libraries.places:places-compat:1.1.0'    


    // 3. After adding the following code upfront --> My app having trouble with Google Play services
    //implementation 'com.android.support:cardview-v7:27.1.1'

}


Could someone give me some insights on how I may fix this problem?
Thanks!

Publicado el 13/02/2020 a las 23:59
fuente por usuario
En otros idiomas...                            

Cookies help us deliver our services. By using our services, you agree to our use of cookies. Learn more